import re
regex = re.compile(r"(?<!\-)\[.+?\](\.\w{3}$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("SampleFileA-[SortCode].xls\n"
"SampleFileB-[SortCode][CRCNum].xls\n"
"SampleFileC-[SortCode][OtherSortCode][CRCNum].xls\n"
"SampleFileD-Date[CRCNum].xls\n"
"SampleFileE-Date.xls\n\n"
"In this example I only want to remove [CRCNum] from the file names.\n\n"
"This is as close as I can get. I just don't know how to use lookbehind properly")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)