import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\-)\\[.+?\\](\\.\\w{3}$)";
final String string = "SampleFileA-[SortCode].xls\n"
+ "SampleFileB-[SortCode][CRCNum].xls\n"
+ "SampleFileC-[SortCode][OtherSortCode][CRCNum].xls\n"
+ "SampleFileD-Date[CRCNum].xls\n"
+ "SampleFileE-Date.xls\n\n"
+ "In this example I only want to remove [CRCNum] from the file names.\n\n"
+ "This is as close as I can get. I just don't know how to use lookbehind properly";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}