import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)\n"
+ " (?<chars>[-\\w]) # equals to A-Z, a-z, 0-9, _\n"
+ " (?<af>=>) # \"arrow function\"\n"
+ " (?<item>\n"
+ " (?!(?&af)) # no af at the beginning\n"
+ " (?:(?&af)?(?&chars)++)+\n"
+ " (?!(?&af)) # no af at the end\n"
+ " )\n"
+ ")\n"
+ "^(?&item)$";
final String string = "Field_name_true2\n"
+ "abc=>d\n"
+ "=>abc\n"
+ "abc=>abc\n"
+ "somewhere_over_the_ocean=>\n"
+ "somewhere_over_the_ocean=>dda\n"
+ "somewhere-over-the-ocean\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}