const regex = new RegExp('(?(DEFINE)
(?<chars>[-\\w]) # equals to A-Z, a-z, 0-9, _
(?<af>=>) # "arrow function"
(?<item>
(?!(?&af)) # no af at the beginning
(?:(?&af)?(?&chars)++)+
(?!(?&af)) # no af at the end
)
)
^(?&item)$', 'gm')
const str = `Field_name_true2
abc=>d
=>abc
abc=>abc
somewhere_over_the_ocean=>
somewhere_over_the_ocean=>dda
somewhere-over-the-ocean
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}