import re
regex = re.compile(r"""
(?(DEFINE)
(?<chars>[-\w]) # equals to A-Z, a-z, 0-9, _
(?<af>=>) # "arrow function"
(?<item>
(?!(?&af)) # no af at the beginning
(?:(?&af)?(?&chars)++)+
(?!(?&af)) # no af at the end
)
)
^(?&item)$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Field_name_true2\n"
"abc=>d\n"
"=>abc\n"
"abc=>abc\n"
"somewhere_over_the_ocean=>\n"
"somewhere_over_the_ocean=>dda\n"
"somewhere-over-the-ocean\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")