#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[(0.\d+|[1-9]\d*\.\d+)\D+((?1))\] *(.*)"
Local $sString = "[105.68 - 143.759] some text" & @CRLF & _
"[143.759 - 173.88] some texT" & @CRLF & _
"[173.88 - 201.839] some text" & @CRLF & _
"[0.88 - 201.839] some text" & @CRLF & _
"[173.88 - 201.839]no space" & @CRLF & _
"[01.88 - 201.839] some text" & @CRLF & _
"[0.88 - 2.01.839] some text" & @CRLF & _
"[0.88 - .201839] some text" & @CRLF & _
"[173.88 - 201.839[ some text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")