re = /\[(0.\d+|[1-9]\d*\.\d+)\D+((?1))\] *(.*)/mi
str = '[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end