# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(0.\d+|[1-9]\d*\.\d+)\D+((?1))\] *(.*)"
test_str = ("[105.68 - 143.759] some text\n"
"[143.759 - 173.88] some texT\n"
"[173.88 - 201.839] some text\n"
"[0.88 - 201.839] some text\n"
"[173.88 - 201.839]no space\n"
"[01.88 - 201.839] some text\n"
"[0.88 - 2.01.839] some text\n"
"[0.88 - .201839] some text\n"
"[173.88 - 201.839[ some text")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.