using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(0.\d+|[1-9]\d*\.\d+)\D+((?1))\] *(.*)";
string input = @"[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}