using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((\d+|(?1))([+*](\d+|(?1)))+\))=\d+";
string input = @"(123+1*1+(1*1)+(1*(123+1)))=1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}