package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\((\d+|(?1))([+*](\d+|(?1)))+\))=\d+`)
var str = `(123+1*1+(1*1)+(1*(123+1)))=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}