re = /(\((\d+|(?1))([+*](\d+|(?1)))+\))=\d+/
str = '(123+1*1+(1*1)+(1*(123+1)))=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end