$re = '/(\((\d+|(?1))([+*](\d+|(?1)))+\))=\d+/';
$str = '(123+1*1+(1*1)+(1*(123+1)))=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);