#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^#+(.+)\n*((?:\n(?:^[^\n#].{0,2}$|^[^\n#].{3}(?<!<!--).*))+)"
Local $sString = "# Style " & @CRLF & _
"This style is suitable for having the header as the front, and the answer as the back" & @CRLF & _
"1 newline" & @CRLF & _
"<!--ID: 1717098832201-->" & @CRLF & _
"# Style " & @CRLF & _
"This style is suitable for having the header as the front, and the answer as the back" & @CRLF & _
"" & @CRLF & _
"1 newline" & @CRLF & _
" " & @CRLF & _
"1 newline with blanks" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 newlines" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"2 newlines with blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"2 newlines mixed blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"<!--ID: 1717098832201-->" & @CRLF & _
"# Overall heading" & @CRLF & _
"## Subheading 1" & @CRLF & _
"You're allowed to nest headers within each other" & @CRLF & _
"" & @CRLF & _
"1 newline" & @CRLF & _
" " & @CRLF & _
"1 newline with blanks" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 newlines" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"2 newlines with blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"2 newlines mixed blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"## Subheading 2" & @CRLF & _
"It'll take the deepest level for the question" & @CRLF & _
"" & @CRLF & _
"1 newline" & @CRLF & _
" " & @CRLF & _
"1 newline with blanks" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 newlines" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"2 newlines with blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"2 newlines mixed blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"## Subheading 3" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"It'll even" & @CRLF & _
"Span over" & @CRLF & _
"Multiple lines, and ignore preceding whitespace" & @CRLF & _
"" & @CRLF & _
"1 newline" & @CRLF & _
" " & @CRLF & _
"1 newline with blanks" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 newlines" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"2 newlines with blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"2 newlines mixed blanks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")