use strict;
my $str = '# Style
This style is suitable for having the header as the front, and the answer as the back
1 newline
<!--ID: 1717098832201-->
# Style
This style is suitable for having the header as the front, and the answer as the back
1 newline
1 newline with blanks
2 newlines
2 newlines with blanks
2 newlines mixed blanks
<!--ID: 1717098832201-->
# Overall heading
## Subheading 1
You\'re allowed to nest headers within each other
1 newline
1 newline with blanks
2 newlines
2 newlines with blanks
2 newlines mixed blanks
## Subheading 2
It\'ll take the deepest level for the question
1 newline
1 newline with blanks
2 newlines
2 newlines with blanks
2 newlines mixed blanks
## Subheading 3
It\'ll even
Span over
Multiple lines, and ignore preceding whitespace
1 newline
1 newline with blanks
2 newlines
2 newlines with blanks
2 newlines mixed blanks
';
my $regex = qr/^#+(.+)\n*((?:\n(?:^[^\n#].{0,2}$|^[^\n#].{3}(?<!<!--).*))+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}