import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^#+(.+)\\n*((?:\\n(?:^[^\\n#].{0,2}$|^[^\\n#].{3}(?<!<!--).*))+)";
final String string = "# Style \n"
+ "This style is suitable for having the header as the front, and the answer as the back\n"
+ "1 newline\n"
+ "<!--ID: 1717098832201-->\n"
+ "# Style \n"
+ "This style is suitable for having the header as the front, and the answer as the back\n\n"
+ "1 newline\n"
+ " \n"
+ "1 newline with blanks\n\n\n"
+ "2 newlines\n"
+ " \n"
+ " \n"
+ "2 newlines with blanks\n\n"
+ " \n"
+ "2 newlines mixed blanks\n\n"
+ " \n"
+ " \n"
+ "<!--ID: 1717098832201-->\n"
+ "# Overall heading\n"
+ "## Subheading 1\n"
+ "You're allowed to nest headers within each other\n\n"
+ "1 newline\n"
+ " \n"
+ "1 newline with blanks\n\n\n"
+ "2 newlines\n"
+ " \n"
+ " \n"
+ "2 newlines with blanks\n\n"
+ " \n"
+ "2 newlines mixed blanks\n\n"
+ " \n"
+ " \n"
+ "## Subheading 2\n"
+ "It'll take the deepest level for the question\n\n"
+ "1 newline\n"
+ " \n"
+ "1 newline with blanks\n\n\n"
+ "2 newlines\n"
+ " \n"
+ " \n"
+ "2 newlines with blanks\n\n"
+ " \n"
+ "2 newlines mixed blanks\n\n"
+ " \n"
+ " \n"
+ "## Subheading 3\n"
+ " \n"
+ " \n"
+ " \n"
+ "It'll even\n"
+ "Span over\n"
+ "Multiple lines, and ignore preceding whitespace\n\n"
+ "1 newline\n"
+ " \n"
+ "1 newline with blanks\n\n\n"
+ "2 newlines\n"
+ " \n"
+ " \n"
+ "2 newlines with blanks\n\n"
+ " \n"
+ "2 newlines mixed blanks\n\n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}