# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^#+(.+)\n*((?:\n(?:^[^\n#].{0,2}$|^[^\n#].{3}(?<!<!--).*))+)"
test_str = ("# Style \n"
"This style is suitable for having the header as the front, and the answer as the back\n"
"1 newline\n"
"<!--ID: 1717098832201-->\n"
"# Style \n"
"This style is suitable for having the header as the front, and the answer as the back\n\n"
"1 newline\n"
" \n"
"1 newline with blanks\n\n\n"
"2 newlines\n"
" \n"
" \n"
"2 newlines with blanks\n\n"
" \n"
"2 newlines mixed blanks\n\n"
" \n"
" \n"
"<!--ID: 1717098832201-->\n"
"# Overall heading\n"
"## Subheading 1\n"
"You're allowed to nest headers within each other\n\n"
"1 newline\n"
" \n"
"1 newline with blanks\n\n\n"
"2 newlines\n"
" \n"
" \n"
"2 newlines with blanks\n\n"
" \n"
"2 newlines mixed blanks\n\n"
" \n"
" \n"
"## Subheading 2\n"
"It'll take the deepest level for the question\n\n"
"1 newline\n"
" \n"
"1 newline with blanks\n\n\n"
"2 newlines\n"
" \n"
" \n"
"2 newlines with blanks\n\n"
" \n"
"2 newlines mixed blanks\n\n"
" \n"
" \n"
"## Subheading 3\n"
" \n"
" \n"
" \n"
"It'll even\n"
"Span over\n"
"Multiple lines, and ignore preceding whitespace\n\n"
"1 newline\n"
" \n"
"1 newline with blanks\n\n\n"
"2 newlines\n"
" \n"
" \n"
"2 newlines with blanks\n\n"
" \n"
"2 newlines mixed blanks\n\n"
" \n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.