import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:NBCRCT\\s+\\d*\\s+[\\w\\d]+\\s+(\\d+))|(?:(?:[A-Z]{2,3}-[A-Z]{2,3})+\\s+[A-Z\\s\\-]+(\\d+))";
final String string = "LOADING PROGRAM VERSION 11.22-0\n\n"
+ "MSS MSSVAL02 2021-06-01 15:45:42\n\n"
+ " CGR NCGR NBCRCT\n"
+ " 1965 VL4MVA2B 310\n\n\n"
+ " STATE CONN COND NUMBER\n"
+ " BL-SY IDLE - 31 \n"
+ " BL-SY BUSSY - 31\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}