import re
regex = re.compile(r"(?:NBCRCT\s+\d*\s+[\w\d]+\s+(\d+))|(?:(?:[A-Z]{2,3}-[A-Z]{2,3})+\s+[A-Z\s\-]+(\d+))", flags=re.MULTILINE)
test_str = ("LOADING PROGRAM VERSION 11.22-0\n\n"
"MSS MSSVAL02 2021-06-01 15:45:42\n\n"
" CGR NCGR NBCRCT\n"
" 1965 VL4MVA2B 310\n\n\n"
" STATE CONN COND NUMBER\n"
" BL-SY IDLE - 31 \n"
" BL-SY BUSSY - 31\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")