const regex = new RegExp('(?:NBCRCT\\s+\\d*\\s+[\\w\\d]+\\s+(\\d+))|(?:(?:[A-Z]{2,3}-[A-Z]{2,3})+\\s+[A-Z\\s\\-]+(\\d+))', 'gm')
const str = `LOADING PROGRAM VERSION 11.22-0
MSS MSSVAL02 2021-06-01 15:45:42
CGR NCGR NBCRCT
1965 VL4MVA2B 310
STATE CONN COND NUMBER
BL-SY IDLE - 31
BL-SY BUSSY - 31
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}