re = /(?:NBCRCT\s+\d*\s+[\w\d]+\s+(\d+))|(?:(?:[A-Z]{2,3}-[A-Z]{2,3})+\s+[A-Z\s\-]+(\d+))/m
str = 'LOADING PROGRAM VERSION 11.22-0
MSS MSSVAL02 2021-06-01 15:45:42
CGR NCGR NBCRCT
1965 VL4MVA2B 310
STATE CONN COND NUMBER
BL-SY IDLE - 31
BL-SY BUSSY - 31
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end