using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) (\S+) (\S+) (\S+) (.+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+)$";
string input = @"05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}