import re
regex = re.compile(r"^(\S+) (\S+) (\S+) (\S+) (.+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+) (\S+)$", flags=re.MULTILINE)
test_str = ("05/02/2018 L0007761 1 13640 Trust Printshop 8394BLK05 8394 BLACK L 104.00 16.77 83.88\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")