import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?!.*\\bdbug\\b)|(?=.*\\bdbug\\b.*\\bfiring\\b)).*$";
final String string = "A log entry containing neither keyword.\n"
+ "A log entry containing only dbug.\n"
+ "A log entry containing dbug and firing.\n"
+ "A log entry containing only firing.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}