$re = '/^(?:(?!.*\bdbug\b)|(?=.*\bdbug\b.*\bfiring\b)).*$/m';
$str = 'A log entry containing neither keyword.
A log entry containing only dbug.
A log entry containing dbug and firing.
A log entry containing only firing.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);