const regex = /^(?:(?!.*\bdbug\b)|(?=.*\bdbug\b.*\bfiring\b)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!.*\\bdbug\\b)|(?=.*\\bdbug\\b.*\\bfiring\\b)).*$', 'gm')
const str = `A log entry containing neither keyword.
A log entry containing only dbug.
A log entry containing dbug and firing.
A log entry containing only firing.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}