re = /^(?:(?!.*\bdbug\b)|(?=.*\bdbug\b.*\bfiring\b)).*$/m
str = 'A log entry containing neither keyword.
A log entry containing only dbug.
A log entry containing dbug and firing.
A log entry containing only firing.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end