const regex = /^((\$?[A-Z]+\$?\d+)(?::(?2))?)(?:,\s*(?1))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\$?[A-Z]+\\$?\\d+)(?::(?2))?)(?:,\\s*(?1))*$', 'gm')
const str = `E5
AA55:E5
DD5555:DDD55555, E5, F5:AA55
\$F7:\$G\$7
bis_document_id
PCR1MM_YPCVolume
sheet_error7
blahE5
training_A1
myNameIsGeorgeJR
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}