$re = '/^((\$?[A-Z]+\$?\d+)(?::(?2))?)(?:,\s*(?1))*$/m';
$str = 'E5
AA55:E5
DD5555:DDD55555, E5, F5:AA55
$F7:$G$7
bis_document_id
PCR1MM_YPCVolume
sheet_error7
blahE5
training_A1
myNameIsGeorgeJR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);