# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\$?[A-Z]+\$?\d+)(?::(?2))?)(?:,\s*(?1))*$"
test_str = ("E5\n"
"AA55:E5\n"
"DD5555:DDD55555, E5, F5:AA55\n"
"$F7:$G$7\n\n"
"bis_document_id\n"
"PCR1MM_YPCVolume\n"
"sheet_error7\n"
"blahE5\n"
"training_A1\n"
"myNameIsGeorgeJR\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.