// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\$?[A-Z]+\$?\d+)(?::(?2))?)(?:,\s*(?1))*$").unwrap();
let string = "E5
AA55:E5
DD5555:DDD55555, E5, F5:AA55
$F7:$G$7
bis_document_id
PCR1MM_YPCVolume
sheet_error7
blahE5
training_A1
myNameIsGeorgeJR
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}