# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:^|\s)(?:[^@\s]*?))(_)((?:[^@\s]*?))(?=@|\s|$)/\1\\_\3/gm;t' <<< "_hi hello i like this char _ write me lol_ _word something_ @myusername_ something_@username_"