use strict;
my $str = '_hi hello i like this char _ write me lol_ _word something_ @myusername_ something_@username_';
my $regex = qr/((?:^|\s)(?:[^@\s]*?))(_)((?:[^@\s]*?))(?=@|\s|$)/mp;
my $subst = '\\1\\\\_\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";