import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^|\\s)(?:[^@\\s]*?))(_)((?:[^@\\s]*?))(?=@|\\s|$)";
final String string = "_hi hello i like this char _ write me lol_ _word something_ @myusername_ something_@username_";
final String subst = "\\1\\\\_\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}