#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:^|\s)(?:[^@\s]*?))(_)((?:[^@\s]*?))(?=@|\s|$)"
Local $sString = "_hi hello i like this char _ write me lol_ _word something_ @myusername_ something_@username_"
Local $sSubst = "\1\\_\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)