use strict;
my $str = 'Dva žáci testovali odskok nového tenisového míčku. Pustili ho z výšky 2,54 metru na hladký, pevný vodorovný povrch a zjistili, že se odrazí do dvou třetin (23) původní výšky.';
my $regex = qr/(?<=(^|\p{Zs}|\b)[vozuskia])(?!\u00A0)\p{Zs}/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";