import re
regex = re.compile(r"(?<=(^|\p{Zs}|\b)[vozuskia])(?!\u00A0)\p{Zs}", flags=re.MULTILINE)
test_str = "Dva žáci testovali odskok nového tenisového míčku. Pustili ho z výšky 2,54 metru na hladký, pevný vodorovný povrch a zjistili, že se odrazí do dvou třetin (23) původní výšky."
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)