#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(([A-Z])\2{0,2}(?:100|[1-9]\d?))\b"
Local $sString = "A1 AA2 AAA3 B100 CC7 ABC1234" & @CRLF & _
"A12 AA21 AAA36 B57 CC76 ABC1234" & @CRLF & _
"UVW1 ABC2 AAAA4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")