using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(([A-Z])\2{0,2}(?:100|[1-9]\d?))\b";
string input = @"A1 AA2 AAA3 B100 CC7 ABC1234
A12 AA21 AAA36 B57 CC76 ABC1234
UVW1 ABC2 AAAA4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}