import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(([A-Z])\\2{0,2}(?:100|[1-9]\\d?))\\b";
final String string = "A1 AA2 AAA3 B100 CC7 ABC1234\n"
+ "A12 AA21 AAA36 B57 CC76 ABC1234\n"
+ "UVW1 ABC2 AAAA4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}