package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<pool>(?<letter>[A-Z])\k<letter>{0,2})(?<number>(100|[1-9]\d?))$`)
var str = `A1
AA2
AAA3
B100
CC7
ABC1234
A12
AA21
AAA36
B57
CC76
ABC1234
UVW1
ABC2
AAAA4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}