import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<pool>(?<letter>[A-Z])\\k<letter>{0,2})(?<number>(100|[1-9]\\d?))$";
final String string = "A1\n"
+ "AA2\n"
+ "AAA3\n"
+ "B100\n"
+ "CC7\n"
+ "ABC1234\n"
+ "A12\n"
+ "AA21\n"
+ "AAA36\n"
+ "B57\n"
+ "CC76\n"
+ "ABC1234\n"
+ "UVW1\n"
+ "ABC2\n"
+ "AAAA4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}