import re
regex = re.compile(r"^(?<pool>(?<letter>[A-Z])\k<letter>{0,2})(?<number>(100|[1-9]\d?))$", flags=re.MULTILINE)
test_str = ("A1\n"
"AA2\n"
"AAA3\n"
"B100\n"
"CC7\n"
"ABC1234\n"
"A12\n"
"AA21\n"
"AAA36\n"
"B57\n"
"CC76\n"
"ABC1234\n"
"UVW1\n"
"ABC2\n"
"AAAA4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")