package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)/\*\N*?\*/(*SKIP)^|/\*.*?\*/`)
var str = `/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}