const regex = new RegExp('/\\*\\N*?\\*/(*SKIP)^|/\\*.*?\\*/', 'gs')
const str = `/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);