import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*\\N*?\\*/(*SKIP)^|/\\*.*?\\*/";
final String string = "/* comment */ not a comment /* another comment */\n\n"
+ "/* delete this *\n"
+ "/* multiline *\n"
+ "/* comment */\n\n"
+ "/*************\n"
+ "/* and this * \n"
+ "/************/\n"
+ "The End";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}