$re = '~/\*\N*?\*/(*SKIP)^|/\*.*?\*/~s';
$str = '/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;