#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)/\*\N*?\*/\K|/\*.*?\*/"
Local $sString = "/* comment */ not a comment /* another comment */" & @CRLF & _
"" & @CRLF & _
"/* delete this *" & @CRLF & _
"/* multiline *" & @CRLF & _
"/* comment */" & @CRLF & _
"" & @CRLF & _
"/*************" & @CRLF & _
"/* and this * " & @CRLF & _
"/************/" & @CRLF & _
"The End"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)