re = /\/\*\N*?\*\/\K|\/\*.*?\*\//
str = '/* comment */ not a comment /* another comment */
/* delete this *
/* multiline *
/* comment */
/*************
/* and this *
/************/
The End'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result