const regex = /^0\.\d{1,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0\\.\\d{1,3}$', 'gm')
const str = `0
0.1
0.12
0.123
0.1234
00
00.1
00.12
00.123
00.1234
1
1.1
1.12
1.123
1.1234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}